Issue
If you purchased Adobe Creative Cloud using your UTD email, you will need to log in to a personal Adobe account to edit or cancel your Adobe paid subscription.
Root Cause
To use education discounts, Adobe sometimes requires a .edu address be used. However, this account is also linked to an Adobe Enterprise organization at UTD.
Resolution Steps
Note: If you do not have an Adobe account with your UTD email (NetID@utdallas.edu), you will not have this option.
- Log out of Adobe and clear your cache and cookies.
- Alternatively, use an incognito or private window.
- Visit Adobe and login using your NetID@utdallas.edu.
- When the "Select an account" option appears, choose Personal Account .
- You will now be logged into your personal account, where you can update billing information or cancel your subscription.
![Adobe login screen with option to choose either personal or company or school account.](https://atlas.utdallas.edu/TDPortal/Images/Viewer?fileName=f99214ac-d9c7-45f3-871f-0ba79e9ca9b3.png)